ICE & HFT 2003 Accord Tourer satellite navigation won't fire up

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Geoff, Thursday 9th Aug, 2012.

  1. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    For some time now my sat nav has only actually come on once in every 2-3 months. It just reads an error and refuses to start up. Apart from not being able to use the sat nav I am also unable to alter the time without the sat nav working. Can anyone help please?
     
  2. Ichiban Founder Staff Team

    England CJ Leeds
    30,181
    6,411
    516
    Hi Geoff and welcome to AOC. When your sat nav does fire up what happens what is the error message you receive?

    have a look at this thread http://hondakarma.com/threads/109/

    let me know how you get along and if you can post pictures of the sat nav so it will be easier to assist you.
     
    Last edited by a moderator: Sunday 23rd Feb, 2014
    Loading...
  3. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    Hi and thanks for your quick response. I tried the procedure for doing a Force Down load but to no effect. I have had it work occasionally when I am carrying a different load and wondered if there could be a cable somewhere that has a loose connection? Not been able to replicate this and it it hasn't worked for several months.

    IMG_0598.

    IMG_0599.


    Do you have any other ideas please?
     
  4. Ichiban Founder Staff Team

    England CJ Leeds
    30,181
    6,411
    516
    Bud don't take this wrong way the amount of dust you have on the front panel would suggest this drive is full of dirt and debris.

    the entire unit needs to come out and dismantled and given a proper clean. try cleaning the DVD and see if that works.
     
    Loading...
  5. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    Hi and a fair point. I wondered if that may be affecting it and have already tried cleaning the DVD. How do i get the unit out to clean it?
     
  6. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,595
    4
    Out of curiosity .. what happened to the tuning knob ?
     
    Loading...
  7. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    It was knocked off and accidentally thrown away. Any idea where I can get a replacement?
     
  8. Ichiban Founder Staff Team

    England CJ Leeds
    30,181
    6,411
    516
    Hi Geoff have a look at this thread Xcarlink ipod Adaptor Install this is how you would remove the dvd rom drive. Can you show me pictures of the sat nav dvd drive too.
     
    Loading...
  9. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    Hi here is the DVD drive

    IMG_0600.
     
  10. mcgowanp Senior Member ★ ★ ☆ ☆ ☆

    I had a similar issue where it would occasionally kick out to the same error. I bought a cleaning CD on eBay . Started it up a couple of times with it and it has worked fine after . I would certainly keep the dust away from it.
    Might be worth checking the disc for scratches also..,
     
    Loading...
    SayamaAccord likes this.
  11. Ichiban Founder Staff Team

    England CJ Leeds
    30,181
    6,411
    516
    Last edited by a moderator: Sunday 23rd Feb, 2014
    Loading...
  12. Geoff Junior Member ☆ ☆ ☆ ☆ ☆

    Hi and thanks again for your responses. I will get a new cleaning kit and try this first of all.
     
    Ichiban likes this.
  13. Ichiban Founder Staff Team

    England CJ Leeds
    30,181
    6,411
    516

    Any luck or success with it?
     
    Loading...