Engine & Gearbox 2003 Accord Type-S oil cooler leaking...

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Cherrie Pop, Thursday 25th Jul, 2013.

  1. Cherrie Pop New Member Getting Started

    Hi my accord has a oil leak coming from the oil cooler, im looking to replace it but reluctant to spend the £400 rowes honda have quoted me just for the part. Does anybody know anywhere i could source one from? ie a breakers yard or something? I've searched relentlessly on the web but to no prevail! any help would be much appreciated! thanks
     
  2. Ichiban Founder Staff Team

    England CJ Leeds
    30,182
    6,411
    516
    leak from the oil cooler? I have very hard time believing the metal body will leak ..do you have a picture and I will not believe that diagnosis for one minute. It can be O rings on the oil filter of even the O ring behind the oil cooler

    On the 2.4 engine you have this set up.

    E__1301.


    On Item thirteen which is the oil filter you have the o ring this is known to leak if you over tighten the filter so you can wrongly assume it the oil cooler. Have a closer look at the filter and O ring if it pinched replace the whole filter and make sure of cleaning the mating surfaces. Check out the DIY for the oil change for torque setting.

    if that is OK unbolt the Oil cooler centre bolt item fifteen and remove the oil cooler to check the O ring behind it, Item nineteen part number 91316-PE7-730 for £3.00 quid.

    please come back with some pictures and let see what you got. BUT don't go an buy that cooler without knowing the root cause.
     
    Loading...
  3. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,595
    4
    If you need it I think I've got an oil cooler, its off a Civic Type-R K20 engine, should be the same. But as CJ says check the O rings first.
     
    Loading...
  4. Cherrie Pop New Member Getting Started

    Hi thanks for the replies I've had the o rings changed and touch wood it hasnt been leaking ill keep you posted if it changes and ill have the cooler off you to replace. while im here ill pick your brains about something else if i can, the ABS and triange w/exclamation light plus VSA light came on i plugged it in and found a rear ABS sensor was faulty i changed that no problem but triangle and VSA light is still on with the code 0084 sensore logic failure??? any ideas I've read honda will replace the VSA module at a stupid £1600!!! any help would be greatly appreciated!
     
  5. Ichiban Founder Staff Team

    England CJ Leeds
    30,182
    6,411
    516
    You need someone locally calibrate you sensors ? Which o rings have you changed? Any pictures ?
     
    Loading...