Electrical & Lights Charging light showing with new battery and correct charging voltages being produced.

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by darren.rogers, Tuesday 27th Nov, 2012.

  1. darren.rogers New Member Getting Started

    The charging light has started to show on my dash recently even though the battery is new and the voltages across the battery terminals are pretty much text book prior to starting, idling and under load. Both I and the guy at the garage have confirmed the charging voltages.

    Does anyone know what else may causes the charging light to light up otherwise ?
     
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,595
    4
    Re: Charging light showing with new battery and correct charging voltages being produ

    There must still be a fault with the alternator. One of the wires coming off the alternator is not at charging voltage when it should be.

    CJ can you find the wiring diagram for the charging circuit please.
     
    Loading...
  3. RobB Expert Advisor ★ ★ ★ ★ ★

    Re: Charging light showing with new battery and correct charging voltages being produ

    Hello Darren, please say hello in the introduction section.
    I agree with Speedy there must be a fault with the alternator.
    What values have you got when its charging.
     
  4. darren.rogers New Member Getting Started

    Re: Charging light showing with new battery and correct charging voltages being produ

    Thanks for replies.
    I get 12.5v on the battery to start with the engine turned off, and then with the engine on 14.5v before load, and again 14.35v with the main lights, AC and blower on full (all taken at the battery)