Electrical & Lights clock and heating backlighting

Discussion in '6th Generation (1997-2002)' started by jbtb, Tuesday 24th Feb, 2015.

  1. jbtb Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom john batt Uxbridge
    22
    1
    Hi all this is a great community and people so far have helped me out.
    The problem I have now is the clock and aircon display on my 1999 honda accord works but there is no backlighting when night driving ! I have pulled out the unit and replaced the two bulbs but this made no change ! The radio and all other buttons light up as they should !
    Any ideas anyone
     
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Are the bulbs attached to a circuit board or do they connect straight to wires via connectors ?
     
    Loading...
  3. jbtb Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom john batt Uxbridge
    22
    1
    Hi they fix directly onto a circuit board
     
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    There maybe an issue with the circuit board, give it a visual inspection see if you can spot anything.
     
    Loading...
  5. jbtb Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom john batt Uxbridge
    22
    1
    Hi I did do a visual before ordering replacement bulbs and could see no issues !
    Do you think it could be a problem further down the line or I need to seek out a replacement unit ?
     
  6. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    I'm not familiar with the 6th Generation per say but I would imagine it's the circuit board.

    If you are comfortable with basic electronics and have a multimeter, you could have a probe around and see what you can deduce from that.
     
    Loading...
  7. exec Premium Member Club Supporter

    United Kingdom London
    2,846
    1,480
    Is this on the climate control unit?
     
    Loading...
  8. Nels Moderator Staff Team

    How is this board electrically connected to the car, a multi-plug or push-in?
    Do the contacts look corroded?
     
    Loading...