Electrical & Lights Coil light flashing and lack of power

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by malraff, Monday 1st Jul, 2013.

  1. malraff New Member Getting Started

    hi guys

    bit of an on going issue

    basically if i accelerate hard some sort of limiter kicks in and restricts my RPM and its impossible to get over 60mph, the starter coil light then starts flashing, and stays lit for 1/200 miles.

    As soon as i stop the car completely, and start of again, i regain power - until i hit a highish RPM in any gear - quite dangerous when over taking!:Aghast:

    so far my mechanic has tried filters, EGR valve, exhaust to no avail

    any one any ideas?

    cheers

    mal
     
  2. Ichiban Founder Staff Team

    England CJ Leeds
    30,133
    6,387
    516
    Hi and welcome , since we have tried to replace all these filters and it not working have you got any DTC codes held on the ECU?
     
    Loading...
  3. malraff New Member Getting Started

    no codes sorry!
     
  4. Ichiban Founder Staff Team

    England CJ Leeds
    30,133
    6,387
    516
    No code you didn't get any or no codes there was nothing held on the ECU?
     
    Loading...
  5. Brodziu Valued Contributor ★ ★ ★ ☆ ☆

    Greg Manchester
    396
    95
    which filters? if you changed fuel filter was it genuine? that issue what you have described clearly indicate that you have low pressure on fuel rail which means that FF need to be changed, but make sure that you use OEM part.
     
    Loading...
  6. Primarycare Expert Advisor ★ ★ ★ ★ ★

    United Kingdom Primary c Northampton
    1,096
    231
    Hi had this was simple as filter. changed for a Genuine not after market don't waste your money - and all is good again .
    Good luck bud
     
    Loading...