General CR-V electric problems

Discussion in 'General Discussion' started by Stephen manley, Saturday 5th Dec, 2015.

  1. Stephen manley New Member Getting Started

    United Kingdom stephen m dudley
    6
    Hi i have 2nd Generation 05 CR-V which has developed some strange electric faults have lost windows.heater blower and central locking .some interior switches operate things they shouldnt.some times can hear central locking clicking in doors.drives fine all lights working.any thoughts very wellcome.
     
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Kinda sounds like a MICU issue.
     
    Loading...
  3. Stephen manley New Member Getting Started

    United Kingdom stephen m dudley
    6
    MICU .is that multiplex module?
     
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Yes..Multiplex Integrated Control Unit
     
    Loading...
  5. Stephen manley New Member Getting Started

    United Kingdom stephen m dudley
    6
    Do you know if its possible to replace at home .have been told it may need to be programmed thanks
     
  6. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    I doubt it on the older gen CR-V, I don't know for sure though.

    Could well be a real pain to get it out as it's integrated with the fuse box I believe.
     
    Loading...
  7. Stephen manley New Member Getting Started

    United Kingdom stephen m dudley
    6
    Hi. 05 CR-V .had lots of strange electric problems no windows.blower.sunroof.centetral locking.eventually found a bolt up under dash that had lots of earth wires on it that was realy loose .tightened up all good.thought it was MICU.unit. so worth checking earth connections first.manual will tell you were there located.
     
  8. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    @Stephen manley can you please keep all related posts in one thread and not keep opening new threads on the same issue.

    I'll go and find your other thread and merge these comments in.
    - - - Updated - - -
    Anyway, good to hear you've resolved the issue and that the fix was straight forward one.
     
    Loading...
    Nels likes this.