Electrical & Lights Cruise control on CR-V, faulty.

Discussion in '3rd Generation (2006-2012)' started by eastern, Sunday 30th Dec, 2012.

  1. eastern Junior Member ☆ ☆ ☆ ☆ ☆

    Have just bought a S/H CR-V and tried the cruise control but it doesn't work. The light comes on on the dash but pressing the "set" button does nothing. Anyone had a fault on their CR-V with the C/Control and can tell me what the problem was or the cure is?
    Thanks Nick
     
  2. Dave Expert Advisor ★ ★ ★ ★ ★

    Probably the cruise control switch on the clutch or brake pedal wants adjusting. Someone will be along to confirm this and hopefully tell you what to do as I've never had to adjust one before.
     
    Loading...
  3. eastern Junior Member ☆ ☆ ☆ ☆ ☆

    Sorted, I have to say there seems to be very little response to questions on the site.
     
  4. Bowler Senior Member ★ ★ ☆ ☆ ☆

    What was the fix?
     
    Loading...
  5. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Nick, regarding not getting a reply, I think you've just been unlucky with your posts. Also I think people were busy with Christmas and New Year.

    I've found that usually round here people are pretty quick to reply.

    Glad you got the issue sorted though and as Bowler says please do let us know what the root cause was.

    I found this thread (dead link removed by staff) which discussed steps on how to diagnose a cruise control issue.
     
    Last edited by a moderator: Sunday 15th Feb, 2015
    Loading...
  6. Ichiban Founder Staff Team

    England CJ Leeds
    30,129
    6,381
    516
    Nick it the holiday season you won't get people available due to commitments, glad you have had a fix please share the fix with others.
     
    Loading...
  7. Ezeetrucker Club Member ★ ☆ ☆ ☆ ☆

    Baz Lincolnshire
    149
    26
    I am always happy to comment , reply to posts. But as I had nothing positive to say regarding the cruise control didn't bother.

    Glad you got it sorted anyway Nick
     
    Loading...
  8. eastern Junior Member ☆ ☆ ☆ ☆ ☆

    Don't worry Ezeetrucker I would only expect an answer from somebody who had the same issue. As it was it was the switch on the clutch pedal, adjusted it slightly and it now works fine.
     
  9. Ezeetrucker Club Member ★ ☆ ☆ ☆ ☆

    Baz Lincolnshire
    149
    26
    Nice one, as I say glad you got it sorted, hope you're enjoying your CR V, I just love mine.
     
    Loading...
  10. eastern Junior Member ☆ ☆ ☆ ☆ ☆

    Thanks, it wasn't really bought for me but I've ended up using it as I sold my VW Passat estate which was the best car I have ever owned and after doing a few long trips in the Honda I miss it even more. There's nothing wrong with the Honda it's just not a patch on the VW for motorways.
     
  11. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Your not comparing like for like there. An Accord would be a better car to compare with the Passat and I'm pretty sure the Accord would easily top the Passat as a motorway cruiser.
     
    Loading...
  12. eastern Junior Member ☆ ☆ ☆ ☆ ☆

    I know the Passats not a CR-V and vice versa, have never driven an Accord so can't comment. Although my Passat had the DSG box so I drove a Honda auto to see what they were like in comparison, needless to say I bought a manual!
     
  13. dkarolj Junior Member ☆ ☆ ☆ ☆ ☆

    Croatia Davor Kutina
    24
    23
    I have just read your post and saw that you sorted out a problem by adjusting clutch switch.

    My problem is Cruise Main comes on and Set does not bring up Cruise Control light/control so there we have(had) the same problem. I tested the switch with multimeter and it works with pedal depressed will check it again today to be sure. I managed to get Shop Repair Manual but just for American market and A/T so I don`t have electrical wiring diagram for my CTDI with M/T.

    No. 3 (under the dash) - 10 amp fuse is checked and OK.

    Also attached is an image to test the Main and multi switch (set/reset) that is based on a string. This is the same for both markets. That switch works great, so that is not the problem.

    Can someone help me get wiring diagram or even a Service Manual for Diesel EU versions of CR-V so I can try to sort out where could the problem presist?

    CRV07_service_manual_ch_1_cruise_control_wiring_diagram_Page_82. CRV07_service_manual_ch_1_cruise_control_wiring_diagram_Page_85.
     
    Loading...
  14. dkarolj Junior Member ☆ ☆ ☆ ☆ ☆

    Croatia Davor Kutina
    24
    23
    Update: Yesterday I managed to test all switches clutch+break and they work fine. Also tested all fuses under the dashboard one by one :Smile:

    So please if someone can help me get the Wiring Circuit Diagram for 07 CTDI Cruise Control it would help.
     
    Loading...
  15. Ichiban Founder Staff Team

    England CJ Leeds
    30,129
    6,381
    516
    Have you tested the cruise control switch on the steering wheel ? If you can't get another one from a working car you will soon know the problem.
     
    Loading...
  16. dkarolj Junior Member ☆ ☆ ☆ ☆ ☆

    Croatia Davor Kutina
    24
    23
    Today I had some time and disassembled the whole steering and gauge set.

    I found wire diagram for I-CTDI manual on Russian (in attachment) so I tested all the wires and cruise control switch on the steering wheel with multimeter all are fine (all diodes D1-D3 are OK). Just before you do any disassemble of wheel disconnect the battery and leave it alone for min. 3 minutes so SRS air bag dries out of charge (there is a danger of air bag deploying while you disconnect the plug on the steering wheel if it is under charge, also have the radio code ready before taking this action). Taking out the gauge cluster is very easy. Just pull out protective plastic and torque out 3 screws. The dash then comes out easy. There is one connector in the back so you pull it out. On that connector wires from cruise control switch are (6 - white and 12 purple)

    Using Google Translate on the Russian wire diagram only suspects are

    ДАТЧИК ЧАСТОТЫ ВРАЩЕНИЯ ВТОРИЧНОГО ВАЛА -VSS speed sensor (cruise control can come on over 40 km/h) - but speed shows fine on gauge so could rule it out
    and CPU in gauge control unit that communicates with ECM

    I will have one more shot with Self-diagnostic Function

    Entering the self-diagnostic function (manual method)
    NOTE: This procedure takes precise timing. Ill may take several tries to enter the self-diagnosis
    mode.
    Before doing the self-diagnostic function,check the No. 10 (7.5 A) fuse in the under-dash
    fuse/relay box and the No. 23 (10 A) fuse in the under-hood fuse/relay box.
    1. Push and hold the SEL/RESET switch button.
    2. Turn the headlights ON.
    3. Turn the ignition switch ON (II).
    4. Within 5 sec.,turn the headlights OFF, then ON and OFF again.
    5. Within 5 sec.,release the SEL/RESET switch button, and then push and release the button three
    times repeatedly.

    Switch Input Check
    At the initial stage of the self-diagnostic function,the beep sounds intermittently,the beeper
    sounds continuously when any of the following switch inputs are switched from OFF to ON:
    Cruise control main, SET, RESUME, CANCEL switches, SEL/RESET switch,parking brake switch,and VSA
    OFF switch.
    The illumination volume (+) and (-) switch (dash lights brightness controller) can be tested by
    turning on the headliights and verifyingthat the dash llights brightness changes as you turn the
    switch from full dim to full bright.

    That are all the tests I can do with the tools I have. If I won't be able to repair it it will have to go at the main dealer to connect it to HDS and try to pinpoint the problem.
     

    Attached Files:

    Loading...
  17. Beefy Expert Advisor ★ ★ ★ ★ ★

    United Kingdom Stoke
    1,115
    685
    1
    could be the SRS reel behind the steering wheel. usually gives problems with the volume button but its possible the give a fault with the cruse control. all the functions on the steering wheel are connected to the reel in order to enable a rotational connection. its possible to view in data list on the HDS what buttons are being pressed on the wheel which would pinpoint the problem
     
    Loading...
    dkarolj and Nighthawk like this.
  18. dkarolj Junior Member ☆ ☆ ☆ ☆ ☆

    Croatia Davor Kutina
    24
    23
    Yes, will need to do HDS and report back when its done.

    I was unable to enter self-diagnostic mode by following of procedure, is it same on EU models of CR-V?
     
    Loading...
  19. printer Junior Member ☆ ☆ ☆ ☆ ☆

    Russian Federation Vadim Moscow, Russia
    10
    10
    The CruiseControl may not work if someone had cut out the particulate filter - check the issue.
     
    Loading...
    dkarolj likes this.
  20. dkarolj Junior Member ☆ ☆ ☆ ☆ ☆

    Croatia Davor Kutina
    24
    23
    Thanks for the info. I didn't see they were connected in any way on the electrical schema.

    The DPF indicator turns on on the gauge during ignition start and I runned some tests with universal AutoCom diagnostic tool. DPF sensor showed 0 mbar diff. pressure and trip since last regen cca. 6500 km. I runned a forced DPF regen and reseted the ECU just in case. I wasn't on the way where official Honda service is in my country but will update here what they found when I get their diagnosis.

    One strange thing I found was when I disconnect the Brake pedal switch the AutoCom diagnostic shows ECU value A - Off (1-2) / B - On (3-4) - look at the diagram in my previous post - as it should be but when I put it back values are the same, Off/Off and when pedal is pressed On/On. Tested the switch and it works as it should one contact on (3-4) ( and when released one off (3-4) and one on (1-2) brake lights. So it could be that I'm getting another +12V/ground from somewhere on my ECU on the 36 ECU pin.-

    I tried to get to 40 km/h (ECU was reading 44 km/h) with sensor disengaged so I get the values On/Off from the brake switch and turn on Set but it doesn't engage. Also runned the Gauge test with AutoCom (could not get it working with procedure from previous post) and the CruiseMain/CruisControl LED works and Main/Set/Res/Cancel button works as they give a beep during the test . So now I think I've done everything I can and will need to leave it for Honda.

    Thanks for all the help.

    Cheers,
    dkarolj
     
    Loading...