General Engine coolant fan on when car is cold

Discussion in 'General Discussion' started by Jackalan, Tuesday 26th Jan, 2016.

  1. Jackalan New Member Getting Started

    United Kingdom Martin Birkenhead
    4
    2
    Hiya

    I have a 2006 honda Civic 1.8 vetec.
    The fan comes on with the turn of the key i did havean engine warning light with a code of p0118.
    I have changed the coolant temp sensor on the nearside top of the engine and cleared the fault the fault hasn't come back on but the fan sounds like its going to take off.

    Any ideas before it goes to an auto electrics

    Cheers
     
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Have you checked the connector, sometimes the wires start corroding on the connector and actually short out.
     
    Loading...
  3. Jackalan New Member Getting Started

    United Kingdom Martin Birkenhead
    4
    2
    Only to the sensor they look ok do u think the fan could have a bad earth?
     
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Do you have climate control switched on when you are hearing the fan ?
     
    Loading...
  5. Jackalan New Member Getting Started

    United Kingdom Martin Birkenhead
    4
    2
    No everything is off
     
  6. Busa1340r Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Yate
    79
    57
    Parts diagram shows sensor in bottom of radiator. I suspect that this may be more likely to control the fan. I think that the one on top of the engine supplies the ECU with engine temp information and the temp gauge on the dash. I would have a look and see if you can see another sensor to the nearside of the bottom hose and temporarily disconnect it and see what happens....
     
    Loading...
  7. jd1959 Valued Contributor ★ ★ ★ ☆ ☆

    Ireland Zack Kilkenny
    367
    180
    If the fan still runs then I would check the fan relay.
     
    Loading...
  8. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    You're spot on @Busa1340r that's actually where the corrosion occurs. That's the sensor and the connector that you need to check @Jackalan
     
    Loading...
  9. Jackalan New Member Getting Started

    United Kingdom Martin Birkenhead
    4
    2
    Just given it a go mate u wer right i took relay off it stopped give the relay a tap and put back in fan has stayed off....run it up to temp its come back on let it cool its stopped going to get a relay tomorrow thanks guys☝☝
     
    jd1959 and Ichiban like this.
  10. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Result !
     
    Loading...
    Jackalan likes this.