Electrical & Lights engine management light

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by J.A.M, Thursday 23rd Feb, 2012.

  1. J.A.M Club Member ★ ☆ ☆ ☆ ☆

    i find that when i sit in a traffic jam for a while, my engine management light (MIL) comes on and stays on. itgoes off at random times, sometimes next time i fill up on diesel , or when i start up or just goes off when driving. i don't really notice much difference in performance. just wondering what it could be.

    i used to think it was just one of the lamba/o2 sensors getting too hot as sitting there idling and not letting the gasses escape properly so throwing up an error code.

    but im not sure. any ideas???
     
  2. Paul Expert Advisor ★ ★ ★ ★ ★

    The only way is to get the faults read ideally by Honda in case it's a specialist ECU. If you are near to Leeds area Ichibanaccord has the specialist dealer hardware capable of reading the codes and does this FOC for members. Failing that try Holdcroft Honda if near stoke or a garage local to yourself. You don't want to be guessing and throwing parts at it without knowing.
     
  3. J.A.M Club Member ★ ☆ ☆ ☆ ☆

    icould take it to my local garage but as the light isnt on all the time, will it still have the error code stored on ECU?
     
  4. Ichiban Founder Staff Team

    England CJ Leeds
    30,177
    6,407
    516
    I would say out of a hunch it will be the VSA or simple a bad earth connection in the engine bay.

    Have you had any bodywork or engine repairs lately? this is purely a speculation due to the MIL being intermittent. You will need an expert to have a look at the ECU and recover it DTC's.
     
    Loading...
  5. J.A.M Club Member ★ ☆ ☆ ☆ ☆

    nah, had no body repairs since I've had her. i will take her to local garage to read the fault codes. and go from there.
     
  6. Ichiban Founder Staff Team

    England CJ Leeds
    30,177
    6,407
    516