Electrical & Lights Front Wipers not Parking Correctly

Discussion in '3rd Generation (2006-2012)' started by Stubbo, Tuesday 12th Jan, 2016.

  1. Stubbo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Stubbo Leigh-on-Sea
    I've a CR-V and an issue with the front Wipers, where by on intermittent they don't stop (well are prone to going for 6-30 wipes, then stopping) and if turning off they just keep going and then stopping randomly.

    Also flicking up for a wipe, or using the screen spray, the Wipers keep going then park half way up the screen etc.

    I think there might be a Technical Service Bulletin in relation to this but wouldn't know where to find it.

    Is this needing a new wiper motor, or relay or stalk to resolve? If so where is the best place to get one? If not how could it be fixed? Also need a new rear wiper motor too (were Wipers problems with these cars?).

    Car details in the garage, but is an 07 (57) 3rd Generation CR-V, 1997CC, Manual.

    Thanks in advance for any help or advice!
  2. Paul1000 Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Paul Neston
    Hi, I had the same problem with a BMW I had, it was the wiper relay, cheap and easy fix.
    That's what I would look at first.
  3. Stubbo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Stubbo Leigh-on-Sea
    Everything I can find online says the front wiper motor is the cause...is apparently a common fault.

    Anyone know the best site to get Honda spares of this nature from?
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    You probably want to eliminate a relay issue first, before looking at replacing something more expensive.