Engine & Gearbox Glow plug light on diesel tourer

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by tonygw, Tuesday 24th Sep, 2013.

  1. tonygw Valued Contributor ★ ★ ★ ☆ ☆

    Hi Guys

    I am posting this on behalf of a firend who has a 2.2ICdti tourer 2006 with 96K on the clock.

    I know very little about these cars apart from what I read on here. He has a problem in that the (from what he has described to me) glow plug light remains on when the engine is running.

    Is this a simple case of needing a new set of glow plugs or is it an indicatoin of a more serious issue possibly?

    Going to find a fault code reader but just trying to help him out at the moment so any clues appreciated.
    Thanks
    Tony
     
    Loading...
  2. Ichiban Founder Staff Team

    England CJ Leeds
    30,130
    6,383
    516
    it could be a faulty glow plug relay. I take the car still starts ok in cold? if you can get your mate to get the codes read it will help.
     
    Loading...
  3. tonygw Valued Contributor ★ ★ ★ ☆ ☆

    Thanks for the quick reply as always :Smile:
    yes as far as I know the car starts fine. but his description of whats wrong isnt great as he isnt mechanically minded.
    He is under the impression the car is down on power but I'm not sure if this is the placebo effect due to the light being on.
    Guess it could be the relay faulty. Needs some investigation me thinks.

    When I get some fault codes I'll report back.

    Cheers
    Tony
     
    Loading...
  4. Ichiban Founder Staff Team

    England CJ Leeds
    30,130
    6,383
    516
    if the car down on power then it can be a combination of a few things fuel,air and mechanical. It will need a good inspection to find the root cause fella.
     
    Loading...