Introductions Headlight trouble and a quick introduction!

Discussion in 'Introduce Yourself' started by liamp, Thursday 15th Nov, 2012.

  1. liamp Junior Member ☆ ☆ ☆ ☆ ☆

    Hello to all!

    I purchased a 2008 58 plate Accord saloon 2.2IDTEC 6 months ago after switching from a petrol guzzling and maintenance heavy Mazda RX8 and honestly love driving my new second hand Accord but have had a little problem with it recently and was wondering if anybody could help me out!

    Basically my passenger side headlamp unit has a mind of its own sometimes just the main beam does not work, other times both the main beam and side light do not work, either way the indicator and high beam is always in working order. If i give the headlight a tap the offending lights come back on until the end of the drive normally. The same thing happens every time i go to use my lights!

    Any suggestions? Loose connection?

    If so is it a do-able DIY fix?

    I look forward to your replies and to being an active member of the club.

  2. Ichiban Founder Staff Team

    England CJ Leeds
  3. Nels Moderator Staff Team

    Welcome to HK @liamp. :welcome:
    We need more information about your car.
    Have you checked for corrosion/loose fitting bulb connection plugs?
    Does your Accord had HID's or standard halogens?
    If you add your car to the garage, it will help us help you.
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    That's an odd one. What do you tap to get the lights to work ? Is it the headlight unit itself ?

    I wonder if there is some sort of earthing issue around there.
  5. MickyB Expert Advisor ★ ★ ★ ★ ★

    Hello and :welcome:to the club
  6. John Dickson Expert Advisor ★ ★ ★ ★ ★

    Welcome to HK Liam :welcome:

    As @Nels says is your Accord an EX-GT with the optional HIDs or standard projector beam headlights that were fitted to the rest of the 8th Generation range?

    Perhaps the light has been removed and replaced following a minor bump when the previous owner had it and if the connectors weren't refitted snugly moisture has eventually got in.

    I'm not aware of any major issues on 8th Generation headlights (I've only ever had a side light bulb blow).

    Would love to see some pictures of your Accord when you get five please mate. :garage:
  7. Ichiban Founder Staff Team

    England CJ Leeds
  8. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    How did a thread from 2012 get dredged up? :Blink: :Laughing: