Electrical & Lights Honda Accord Dashboard Illumination not working after fitting new stereo

Discussion in '6th Generation (1997-2002)' started by superguitarman, Friday 21st Aug, 2015.

  1. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Hi guys, just fitted a new stereo in my Accord, and now the dashboard doesn't illuminate when I turn the lights on. Someone please point out my obvious mistake, I've yet to look at fuses since its 7 in the morning and I've just discovered this on my way to work haha. Thanks in advance for any help!
     
    Loading...
  2. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Think I've wired up the earth to the wrong thing haha. After a bit of research there is no earth from the car, you have to make your own.
     
    Loading...
    Chunkylover53 likes this.
  3. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Good to hear you sussed it.
     
    Loading...
  4. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    It's killed my seat electrics as well, I've still not fixed it as I'm still at work but I think that may be the issue, though now I'm suspecting I've broken something a bit more serious with the seat electrics being kaput. Will investigate more when I get home
     
    Loading...
  5. RogerH69 Premium Member Club Supporter

    South Africa Roger Oxford, UK
    2,551
    1,716
    14
    I'm no good at car electrics, but first thing I'd do is check fuses (as you mentioned). You could also try to remove power going to the stereo and see if stuff starts working again. Very general advice I know, all I can think of :Smile:

    All this aside, how is the new stereo working ? :Smile:
     
    Loading...
  6. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    That's a 20Amp fuse on the passenger side, I'm almost certain that's the issue.

    By my count I've blown over 5 fuses when fitting footwell lighting and a new sound system!
     
    Loading...
    RogerH69 likes this.
  7. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    A lot of places I've looked at saying I may have fried the multiplexer. I sincerely hope not.
     
    Loading...
  8. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Would fitting a stereo wrong blow the seat electrics fuse?
     
    Loading...
  9. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    Logically no, but I've blown so many fuses by simple wiring mishaps.
     
    Loading...
  10. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    That's why I'm thinking the multiplexer may be what's gone bang.
     
    Loading...
  11. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    I sure hope not, best replace the fuse and see what happens.
     
    Loading...
  12. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Just seems strange that it's taken out my dash and tail lights AND my seat.
     
    Loading...
  13. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    Ouch, I didn't realise that the tail lights went too.
     
    Loading...
  14. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Yeah.... I know where I've gone wrong in the wiring of the stereo, I'm hoping it's a case of stuff on the same circuit blowing fuses.
     
    Loading...
  15. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Could well be multiplexer !

    We have had someone on here fry one on an Accord
     
    Loading...
  16. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Bollocks. I'll have a proper look in a bit when I've got my tools. See if I can't coax it into life. I'm hoping I've just grounded it out.
     
    Loading...
  17. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Stereo works fine to be fair, no faults apart from it seems to work at the expense of my tail lights and dash lights. And what good is a stereo if you can't drive after dusk without risking having you collar felt by the fuzz or having somebody plow into the back of you?
     
    Loading...
  18. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    That definitely doesn't sound right !!!!
     
    Loading...
  19. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    I think it's because there was a spare wire coming from the old loom which I was using to connect to the new loom and I just went ahead and wired my earth to it haha. I was tired, give me a break haha
     
    Loading...
  20. superguitarman Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Jono Mansfield
    66
    18
    Said wire was labelled "illumination" and was orange so I've definitely fucked up there
     
    Loading...