ICE & HFT Honda Legend 2009 Bluetooth HFT Issues

Discussion in '4th Generation (2004-2012) [Acura RL]' started by garry1981, Saturday 12th Dec, 2015.

  1. garry1981 Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Garry Edinburgh
    9
    7
    Hi, I have recently purchased a Honda legend. Firstly what a great car, unfortunately the HFT did not work though. I got around this by buying a parrot minikit as I heard it would more than likely be an expensive fix. The strangest thing happened today though. I was in reverse and for some reason I pressed the phone button and it worked. While in reverse I could connect my phone and make calls etc and it stays connected when I put it in any other gear but does not work. Fine in reverse though. The button only beeps when in reverse. Anyone had the same problem?
     
    Loading...
  2. vincemince Top Contributor ★ ★ ★ ★ ☆

  3. Legendliving Club Member ★ ☆ ☆ ☆ ☆

    That's a weird one. I was once told by a dealer having checked the codes that my HFT needed replacing because it was drawing power all the time. They quoted £1200 plus labour. I ignored them, bought a new battery and it has worked fine for the four years since. Apparently according to the American owners they are very occasionally prone to a loose connection where the unit plugs in and that might be worth exploring.

    These are amazing cars and worth persevering with, for such complex vehicles, overall they are very reliable, I've done 124k, it still drives like new and I plan to do another 100k at least before I move it on.
     
  4. Sadsack Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Mo Cheshire
    208
    87
    I can't help on this one afraid unless you're open to some suggestions from me about how to get around problems rather then solve.....

    First thing I would do is whenever I want to make a phone call then drive in reverse....

    Joking aside hope you get it sorted and let us know once fixed. Was it not covered under warranty or was it a private sale?
     
    Loading...
  5. garry1981 Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Garry Edinburgh
    9
    7
    There is no literally no info online. I would have thought that maybe an accord owner might have had the same problem. I assume it's the same system. Definitely a strange one. Do have warranty, spoke to the salesman today and need to call tomorrow and book it in.
     
    Loading...