Electrical & Lights Immobiliser Problem

Discussion in '6th Generation (1997-2002)' started by vtecjay, Saturday 12th Jul, 2014.

  1. vtecjay Club Member ★ ☆ ☆ ☆ ☆

    Jamie Bridgwater
    138
    39
    My car start up an then cuts out straight away an the green key icon flashes... what can It be? Jiggle the key about an normally sorts it out... really annoying.
    Any help is really appreciated
     
  2. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    9,206
    2,977
    3
    Sounds like a transponder issue to me, @Chunkylover53 knows a bit about the key/immobiliser set-up on the 6th Generation.
     
    Loading...
  3. moob Valued Contributor ★ ★ ★ ☆ ☆

    Scotland Rob Glasgow
    495
    138
    Flashing key icon means the key isn't recognised.
     
    Loading...
  4. vtecjay Club Member ★ ☆ ☆ ☆ ☆

    Jamie Bridgwater
    138
    39
    It does it with both they keys I have for the car mate.
     
  5. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    9,206
    2,977
    3
    I'd be sure it's an issue with the transponders on the keys being read by the immobiliser. The immobiliser is where I'd look for the problem, as two keys having iffy transponders is unlikely.
     
    Loading...
  6. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    Yup as DD said - it looks like there's an immobilizer issue. Or the ignition barrel is on its way out, try jiggling it whilst driving slowly and see if the green indicator reappears?
     
    Loading...
  7. vtecjay Club Member ★ ☆ ☆ ☆ ☆

    Jamie Bridgwater
    138
    39
    It done it while driving earlier but it was flickering so fast that it just felt like a misfire. Switched key of an back on an all was ok.. might get it plugged in to see if it's throwing a code up.
     
  8. Chunkylover53 Expert Advisor ★ ★ ★ ★ ★

    Almost certain its a barrel issue then
     
    Loading...
  9. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    Barrel issue is a pretty well known problem, happened on my 6th Generation where it was cutting out for no reason. The garage knew straight away to check it and after replacing it worked perfectly ever since, so it could be worth this checking out?
     
    Loading...
    Chunkylover53 likes this.
  10. vtecjay Club Member ★ ☆ ☆ ☆ ☆

    Jamie Bridgwater
    138
    39
    Oh ok ill check that out! What's involved in changing the barrel? Ie recoding keys etc
     
  11. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    I'm not sure to be honest, the garage did it. There'll definitely be someone on here that will know though.
     
    Loading...
  12. vtecjay Club Member ★ ☆ ☆ ☆ ☆

    Jamie Bridgwater
    138
    39
    Thanks for all the advice guys.. going to look into replacing the barrel.
     
    DeviateDefiant likes this.
  13. exec Premium Member Club Supporter

    United Kingdom London
    2,857
    1,486
    Changing the ignition switch just involves removing old one and putting new one, I think some soldiering is needed, you don't need to change the barrel. There is a guide on a uk accord owners forum.
     
    Loading...
    vtecjay likes this.