Aftermarket Kit Just USB support?

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Pilot, Tuesday 27th Oct, 2015.

  1. Pilot Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Daniel London
    97
    14
    This is probably a semi-common question around here, but is there an adapter for my Accord (with 6CD changer built into the stereo) that would be only for USB support? I don't need Bluetooth or SD card support, simply only USB...even though yes if it has other support I'll take it.

    I looked at those Xcarlink and others, but I think I'll just be overpaying for the features I simply do not need, something simple would be good enough for me, and I wonder if any of you have some alternatives installed yourself other than the most recommended here Xcarlink? Thanks
     
    Loading...
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    There's Grom USB and another aux module that I can't think of the name of.

    I think they will all be about the same amount though.

    Does anyone have any suggestions ? @Staff ?
     
    Loading...
  3. dinoc Senior Member ★ ★ ☆ ☆ ☆

    Romania Bucharest
    287
    77
    4
    The cheapest/simplest option from gromaudio is Grom AND2 (USB stick and Android phone support through the same USB port).
    Or top of the line USB3 unit where the USB port gives support for all devices (USB stick, Android phone and Apple phone).
     
    Loading...
  4. Duc de Pommfrit Moderator Staff Team

    United Kingdom Chester Northumberland
    2,922
    1,857
    I was going to suggest Grom
     
    Loading...
  5. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    9,206
    2,976
    3
    To name a few there's:
    • Xcarlink
    • GROM
    • Connects2
    • Eonon
    I'd recommend GROM or Xcarlink personally. Bare in mind the club has an Xcarlink 10% discount available.

    I personally use the Eonon which I don't think is available anymore (and does have an annoying issue too).
     
    Loading...
  6. Pilot Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Daniel London
    97
    14
    Thats great guys thanks. Could any of you do me a favor though and link the exact either and or grom that would fit with my 6 cd changer non nav unit though as I want to be sure I get the right one....I also plan on getting usb wire into the glovebox. And what would be discount code...I just want to go with cheapest option. Cheers
     
    Loading...
  7. dinoc Senior Member ★ ★ ☆ ☆ ☆

    Romania Bucharest
    287
    77
    4
    Loading...
  8. tals Premium Member Club Supporter

    United Kingdom Miles Romsey
    46
    9
    Currently I use a bluetooth to fm transmitter which works well but this looks a much tidier solution. The one I am looking at is Honda Wireless Bluetooth Streaming Handsfree Interface :: HONDA :: XCarLink anyone able to point me to the discount code?

    Anyone have any experience of the unit, I found the fitting instructions which don't seem too bad.

    ** Apologies for the slight thread hijack as I know this is a bluetooth rather than a USB connection but didn't think a new thread was warranted **
     
    Last edited: Friday 30th Oct, 2015
    Loading...
  9. Pilot Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Daniel London
    97
    14
    Loading...
  10. cwall22 Club Member ★ ☆ ☆ ☆ ☆

    England Chris telford
    27
    7
    I had an io Play 2 in my Astra H, i just need to buy an adapter for the Accord for around £20. But its an awesome bit of kit. Well worth checking out as an option :Smile:
     
    Loading...
  11. Pilot Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Daniel London
    97
    14
    So I went through installation on Saturday, all went great...there was a hiccup though.

    When I connected my xcarlinx to the stereo, it gave no sign of life, it didn't work, my unit just kept playing radio, doesn't respond if I press or hold CD/AUX because xcarlinx didn't seem to work.
    So I tried reconnecting both ends of wire again one to the xcarlinx and the other end to the back of my stereo...again, didn't work but then I went out to check something on PC, came back, switched on car...and it worked, and I knew it works because the blue lights came on the xcarlinx, so I was happy, tested it some more switched car on and off, disconnected and reconnected wire to be sure it's all good and it worked flawlessly.

    Since then I haven't tried it until this evening....and yeah, I switch on my car and the xcarlinx doesn't light up, it doesn't play anything...I am fuming because all worked and now it doesn't...and all dash parts are already installed....

    Any clues or could it just be faulty device? Besides, I figured it would look fancy too, but they sent me a white colored one which....is sorta cheap even though it doesn't bother me too much if it worked.... I'll send same reply to them guys and see what they can do...
     

    Attached Files:

    Loading...
  12. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Hard to say, can only guess that it's a connection issue somewhere. Have you done everything as per the instructions ?

    Have a look through this guide "xcarlink" MP3 Unit Install
     
    Loading...
  13. Pilot Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Daniel London
    97
    14
    Yes I have and I mean it was working, I pushed the cables in couple of times and they were in tightly, it was working the last time I have drove until today when I tried to check it.

    PS mine is non nav Accord, thus I didn't have to remove top center dash panel, nor the stereo, could plug in by removing the bottom part only/space area above lighter. I am like 101% sure it's connected correctly and tight.
     
    Loading...