Electrical & Lights Map light/door light not working

Discussion in '3rd Generation (2006-2012)' started by Steve8274, Monday 1st Feb, 2016.

  1. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    hi all
    My front passenger door light has stopped working. The one near the interior mirror. I have changed the bulb. It doesn't work when door is opened or when you press it to use as a map light.
    Any ideas how to fix?
     
    Loading...
  2. legend-ary Moderator Staff Team

    United Kingdom Legend The Big Smoke
    3,797
    2,254
    6
    Hi Steve, have you checked dome light fuse located in the interior fusebox? The fuse box cover usually has a listing on it for which fuse is what.
     
    Loading...
  3. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    All the other interior lights work. The passenger one doesn't light up but the drivers one does so didn't think it could be a fuse
     
    Loading...
  4. legend-ary Moderator Staff Team

    United Kingdom Legend The Big Smoke
    3,797
    2,254
    6
    oh right sorry misread it in first attempt.
     
    Loading...
  5. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    You need to get a multimeter out and check if there is +12v present as well as ground continuity.
     
    Loading...
  6. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    Using the prongs that the bulb slots into? Or do I need to take cover right off to expose wires?
     
    Loading...
  7. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Yes the prongs where the bulb slots into would be fine.
     
    Loading...
  8. Ichiban Founder Staff Team

    England CJ Leeds
    30,101
    6,367
    516
    You are not using LED bulbs are you ? if you are just flip it around and see if it works.
     
    Loading...
  9. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    @SpeedyGee
    Ok
    So just checked with multimeter. Prongs to rear have 12.2v
    Prongs nearest windscreen has no output including earth.
    There is a strip of metal between the 2 prongs and that is earth.
    Does this make sense and correct?
    @Ichiban
    I purchased led lights to replace this one which I thought had blown. Had tried turning bulb round and using original bulb without joy.
     
    Loading...
  10. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Does the light have built in mechanism that can switch the light on and off ? I guess it does. maybe that has had some failure ?
     
    Loading...
  11. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    Yes there is a switch, but it makes no difference if you press it
     
    Loading...
  12. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    I'm guessing that switch has failed somehow.
     
    Loading...
  13. chunkymonkey Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Gary Lincs
    203
    108
    Same problem here on the same light, it's got me puzzled too
     
    Loading...
  14. Wizard Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Andy Surrey
    95
    30
    Have you tried swapping the bulbs from passenger to drivers side & vise verser?
     
    Loading...
  15. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    Yes. Tried that at start but still didn't work. The passenger bulb did work in driver side
     
    Loading...
  16. Tear101 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Lee Northants
    38
    18
    Just a quick question on this subject, does your map light come on when you open the door? On my 08 CR-V only the dome light comes on when the door is opened.
     
    Loading...
  17. Steve8274 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Steve Wigan
    67
    12
    Doesn't work by opening door or by pressing button. Drivers side does by either method.
     
    Loading...
  18. Tear101 Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Lee Northants
    38
    18
    My 07 map lights don't come on when the door is opened but work fine when you switch them on! guessing on my model only the dome light is hooked up to the doors!
     
    Loading...
    Green teapot likes this.
  19. Wizard Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Andy Surrey
    95
    30
    My 09 is the same, dome light in centre comes on with doors and map lights only work on the switch (pressing the actual light).
     
    Loading...
  20. chunkymonkey Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Gary Lincs
    203
    108
    Any resolution on this problem yet? I have not had time to look at mine yet
     
    Loading...