General Passenger Wiper Judder (Occasional with light rain)

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Accord_N22, Tuesday 25th Nov, 2014.

  1. Accord_N22 Top Contributor ★ ★ ★ ★ ☆

    629
    338
    8
    Hi All

    The wipers on my 7th Generation are genuine Honda and are only 7 months old.
    Ever since they have been installed they always seem to lightly judder when it lightly rains. Upon heavy rain its seems to be ok.

    Would the cause of the juddering be because the wiper arm is slightly bent perhaps?

    Thanks all?
     
    Loading...
  2. moob Valued Contributor ★ ★ ★ ☆ ☆

    Scotland Rob Glasgow
    495
    138
    Had the same problem with my accord when I had it. I think it's possibly one or a number of the following :

    Contaminated windscreen
    Bent arms
    Contaminated blade
    Improperly fitted blade
    Poor quality screenwash.
     
    Loading...
  3. Dave Expert Advisor ★ ★ ★ ★ ★

    Mine does it too even with brand new blades from Honda!
     
    Loading...
  4. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    It's getting cold ain't it
     
    Loading...
  5. Duc de Pommfrit Moderator Staff Team

    United Kingdom Chester Northumberland
    2,922
    1,857
    Mine stopped with brand new ones from Honda
     
    Loading...
  6. Dave Expert Advisor ★ ★ ★ ★ ★

    Doesn't make any difference with the temperature actually think my drivers one does it a bit too.
     
    Loading...
  7. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    I blame made in Vietnam rubber quality the japanese one didn't do that. however if you visit eurocar parts they sell Denso japanese wiper blades for the 7 gen try them and see if that makes the difference,

    I Hama going to stock pile on japanese wiper blades for the 8th Generation as they are perfect.
     
    Loading...
    Superman001 likes this.
  8. Dave Expert Advisor ★ ★ ★ ★ ★

    So genuine Honda ones are from Vietnam?
     
    Loading...
  9. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    For the 7th Generation yeah, 8th Generation still Japan.
     
    Loading...
  10. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    Sounds like muck on the windscreen - clean the windscreen using meth spirits on a bit of cloth and plenty of elbow grease. Clay bar the windscreen too.

    Had this issue myself, doing this and new blades solved the issue.
     
    Loading...
    Sprockutt likes this.
  11. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    9,206
    2,976
    3
    I have this issue and with brand new OEM blades, my old set were perfect. I put it down to needing to needing to do a proper decontamination/deep clean on the windscreen. I use AutoGlym Fast Glass on it regularly, and while it looks fine, it's really just smudging in all the unseen oily residues.
     
    Loading...
  12. Accord_N22 Top Contributor ★ ★ ★ ★ ☆

    629
    338
    8
    Thanks guys for your input.
    Didn't know the wiper blades were made in Vietnam.

    Shall have a proper decontamination of the windscreen, I should have some autoglym fast glass lurking about.

    I checked eurocarparts and they only have the drivers side denso ones in stock. Shame, was going to try a pair.
     
    Loading...
  13. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    Have you got access to Costco? They do Goodyear blades at a great price (about £7 I think) and I've found them excellent and last for ages. My windscreen can suffer badly where I work because of the fallout, I have to be careful not to wash and wipe before manually removing the crap from my windscreen otherwise I'm just dragging a whole world over pain over the glass and scoring it whilst wrecking the blades also!
     
    Loading...
  14. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    I have some Bosch Aero ones on my car - they solved my issues as well, quite too. Lasted through last winter which was better than the OEM ones did.
     
    Loading...
  15. Old Cruiser Senior Member ★ ★ ☆ ☆ ☆

    pete slough
    194
    19
    Funny reading all this , just been out to try and clean my windscreen for similar reasons, looking on www.wiperblades.co.uk they have the aero twin pack for £23 saying they are 26'' driver and 16'' passenger can anyone confirm these are the right sizes.
    Cheers Pete
     
    Loading...
  16. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    Sounds about right to me mate.
     
    Loading...
  17. Old Cruiser Senior Member ★ ★ ☆ ☆ ☆

    pete slough
    194
    19
    Thanks mate, just ordered some bosch ones off Ebay for £17
     
    Loading...
  18. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    Absolutely detest everything that is Bosch rather have Vietnamese ones on my car than zee jeeeermaaan gear,:hunter:
     
    Loading...
  19. foxleys Premium Member Club Supporter

    England Jersey
    95
    23
    The Bosch Aero from wiperblades worked well for me - got them about 7/8 months ago.

    Sorry Ichiban!

    I had the Honda ones before and had problems as listed above & they did not last very long, must be our sub tropical climate down here! opps.

    BTW Articfire, I just looked at Costco (I don't know who they are, do they require membership - we don't have them here in Jersey) and no wiper blades listed.....................
     
    Loading...
  20. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    Well everyone can't be perfect fella, I would have gone for the denso ones from eurocar parts. :Wink:Here cheap than the germans

    Denso Honda