Electrical & Lights Quick Diagnostic Question

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Phil1978, Wednesday 2nd Jul, 2014.

  1. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    Mornin all.

    My VSA light is coming on every now and again, will I need to have it scanned with the proper Honda diagnostic gear, or will any code reader read these faults?
     
    Loading...
  2. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    Sorry put this in Civc section for some reason :Whistle: could one of you kind mods move it to the Accord section please :SOS:
     
    Last edited: Wednesday 2nd Jul, 2014
    Loading...
  3. Ichiban Founder Staff Team

    England CJ Leeds
    30,176
    6,405
    516
    This under heavy breaking or just normal driving, if it is the latter just check the connector to the ABS unit in the engine? Or it could be a case of bad ground\earth for it to do it intermittently ?
     
    Loading...
  4. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    Thanks CJ, it happens completely randomly, I'll have a look at the ABS unit next time I go to the car,
     
    Loading...
  5. Nels Moderator Staff Team

    @Phil1978 - thread moved to 7th Generation Accord :Smile:
     
    Loading...
  6. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    Thanks @Nels

    I've had a look at the ABS unit, all seems Ok but I gave the plug and wiring a wiggle anyway, then 2 trips to the tip with no light on.
    I'll be getting her in for a summer service soon so I'll give her a good look over then.
     
    Loading...
  7. Ichiban Founder Staff Team

    England CJ Leeds
    30,176
    6,405
    516
    It will the rear ABS sensors fella , unless it’s a diesel the dreaded 66-1 will need modulator repairs.
     
    Loading...
  8. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    NA, nothing but 2400ish of the finest Japanese cubic centimetres here.
    The light hasn't been on again, but I'll still give the sensors a once over during service.
     
    Loading...
  9. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    I'm sure this is exactly what happened with my brothers Civic just a few months ago. I'll double check, don't think it was too expensive to fix.
     
    Loading...
  10. DeviateDefiant Co-Founder Staff Team

    United Kingdom Leo Northants
    9,206
    2,977
    3
    @Phil1978 my K24 '03 did this from time to time, sometimes there would be weeks between, sometimes it would happen more than once in the same day. I never got around to getting it looked into but I'm sure it was a sensor issue.
     
    Loading...
  11. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,595
    4
    Sometimes they just need connecting to HDS and having calibrate done on them.

    Worked for me on mine a few years back
     
    Loading...
  12. Ichiban Founder Staff Team

    England CJ Leeds
    30,176
    6,405
    516
    @Phil1978 has this gremlins disappered fella or you still living with it?
     
    Last edited: Friday 15th Aug, 2014
    Loading...
  13. Phil1978 Top Contributor ★ ★ ★ ★ ☆

    Phil Salisbury
    610
    208
    1
    Seem to have vanished for now @Ichiban I'm still going to have a quick look around when I do the front brakes next weekend.
     
    Loading...
  14. Ichiban Founder Staff Team

    England CJ Leeds
    30,176
    6,405
    516
    Good stuff take pictures fella good hear the Christmas tree has done one.
     
    Loading...