Electrical & Lights Rear window demister not working

Discussion in '6th Generation (1997-2002)' started by Mazeyshane, Friday 4th Mar, 2016.

  1. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Hello, i have driven my honda for the first time today and i have noticed the rear demister does not work when the button is pushed in, could this be a fuse or the window? Has anyome.else had this problem? Thanks
     
    Loading...
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    I'd examine the heater element very closely see you can spot any breaks where the element has actually burnt out.

    On both sides of screen there will be a wire connecting to the element, check the connection itself for corrosion and also sometimes a connection can break off the element totally.

    Next thing to do, is get a multimeter and connect it up to both connections, see if there is a voltage present. There is a relay, fuse (sorry I don't know the locations of these) and of course a switch involved all of which could have failed. Does the light come on indicating that the demister should be on ?
     
    Loading...
  3. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Ivw tried to look at the elements but someone has tinted it very badly so i can't see them properly.

    The light comes on as tho it should be on but nothing happens, where abouts are the connections? Because i need to sort it, the window tint is put on bad enough and its all wavey so i can't see proper as it is, never mind it being misted up all time:Frown:
     
    Loading...
  4. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    I have checked the elements and they all seem to be nice and orange so it can't be that, really need find out Why it isnt working
     
    Loading...
  5. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Have you checked for voltage at the terminals ?
     
    Loading...
  6. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Where abouts are the terminals mate?
     
    Loading...
  7. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Normally one on each side of the screen.
     
    Loading...
    Nighthawk likes this.
  8. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Ill go have a look mow see if i can find them mate
    - - - Updated - - -
    Just had a look and can't seem to see any mate, would i have take the c pillar off? If so.how do you take it off?
     
    Loading...
  9. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Loading...
  10. exec Premium Member Club Supporter

    United Kingdom London
    2,846
    1,480
    Not 100% sure but I think its on the side

    Capture.PNG
     
    Loading...
    Nighthawk and SpeedyGee like this.
  11. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Would i have to remove the c pillars to get to the terminals?
     
    Loading...
  12. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    They normally hide them behind the C pillar trim to keep a neat finish....
     
    Loading...
    exec likes this.
  13. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Ok thanks, how woulx you remove the c pillars? Just give thrm a tug or?
     
    Loading...
  14. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    I don't know the design of the 6th Generation but generally speaking, you would peel away the door seal where it touches the trim as it helps to seat the trim into place. With that away you should be able to see where the clips are. Give them a gentle tug and it should come loose.

    Others here with 6th Generation Accords will hopefully be able to give you a better description. Whenever I have removed interior trims, I normally figure it out as I go as the basics are the same

    Good luck
     
    Loading...
  15. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Ok mate cheers will give it ago this weekend:Smile: thanks for all the help everyone, will keep you all updated :Smile:
     
    Loading...
  16. exec Premium Member Club Supporter

    United Kingdom London
    2,846
    1,480
    You might need to rmeove the side bolster too

    Capture.PNG
     
    Loading...
    Nighthawk likes this.
  17. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    From that diagram, it looks like the side trim will just pull off.
     
    Loading...
  18. Nighthawk Guest

    United Kingdom Richard Milton Keynes
    5,369
    3,141
    14
    All you need is just enough access to get a multimeter prong stuck onto the terminals
     
    Loading...
  19. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Ok thank you, ill have ago on the weekend and see if i can het it to work orsomet, thanks alot :Smile:
     
    Loading...
  20. Mazeyshane Club Member ★ ☆ ☆ ☆ ☆

    Have found out why it don't demist, obw of the connectors has snapped and been tucjed away:Frown: anyone know where and how much it would be to get a new or used obe fitted??
     
    Loading...