ICE & HFT Sat Nav Update

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by mgm42, Friday 8th Jun, 2012.

  1. mgm42 Junior Member ☆ ☆ ☆ ☆ ☆

    Hi Everyone,

    This question has probably been asked before but I can't find an answer on AOC for it.

    My sat nav is ver 2.00 - APN2-22103.

    I want to update to the latest version but £165+VAT seems very steep.
    My question is what versions could I use between the latest and my version?
    I could then hunt on ebay for older compatible originals.

    Is there a compatibility table someplace?

    Cheers
     
  2. Ichiban Founder Staff Team

    England CJ Leeds
    30,130
    6,383
    516
    Search on the forum bud you will find two threads. It has info on both voice activated and non voice activate discs.yours is the non voice activated one.
     
    Loading...
  3. Nav Senior Member ★ ★ ☆ ☆ ☆

    Anything with a 2. version should work on yours..
     
  4. mgm42 Junior Member ☆ ☆ ☆ ☆ ☆

    Thanks Guys I appreciate your replies. I will find the two threads and read them. But I think Nav has answered my question. Cheers
     
  5. Ichiban Founder Staff Team

    England CJ Leeds
    30,130
    6,383
    516
    Here you go just in case you don't find it :Thumbup:. I would also avoid using cloned DVD's and always go higher than your current version to keep the unit happy. There are ways and means to downgrade and fix the issue is you do accidentally cause an issue. The fixes to those threads are also here.:Wink:

    http://hondakarma.com/threads/123/
     
    Last edited by a moderator: Sunday 23rd Feb, 2014
    Loading...
  6. mgm42 Junior Member ☆ ☆ ☆ ☆ ☆

    Thanks. I don't know why I didn't see this before. Maybe my search criteria spelling was wrong :Whistle:. I don't plan to use cloned DVDs only genuine ones.
    Thanks again