Suspension, Steering and Brakes Shock Absorbers

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by ArcticFire-Account Closed, Wednesday 14th Aug, 2013.

  1. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    Last week I've noticed a squeak coming from the left hand side of the car whenever I go over bumps and at first it sounded like it was from the inside. It's getting worse though and when I bounced the rear N/S of the car I can hear the suspension making a creaking sound. Could this be the shocks or could it just be the rubber? I'm wondering if there's a way of knowing for sure, the only thing I'm aware of is checking for them leaking.

    Car has done 68K miles, I'm guessing this is normal considering the state of the roads.


    Cheers



    EDIT: I think it's the front, when I go over speed bumps it squeaks when the front mounts the bump. I don't think it's shocks though, perhaps drop links or a rubber seal somewhere. Will have to get it up on the ramps.
     
    Last edited: Wednesday 14th Aug, 2013
    Loading...
  2. jayok Club Member ★ ☆ ☆ ☆ ☆

  3. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    Most probably drop links
     
    Loading...
  4. ArcticFire-Account Closed Banned Getting Started

    Scotland Graham Scotland
    3,521
    1,051
    7
    Ah, drop links! I had to do those on my 6th Generation! Strangely, last week I went to the jet wash and did a thorough blast in that area and the squeak has now gone! Maybe something had lodged in there?
     
    Loading...
  5. Ichiban Founder Staff Team

    England CJ Leeds
    30,120
    6,377
    516
    must have been some thing tapped now washed away.
     
    Loading...