Engine & Gearbox Stalling & Hard to start

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by trailblazzer, Monday 7th May, 2012.

  1. trailblazzer Club Member ★ ☆ ☆ ☆ ☆

    Hi Guys,

    I've got my accord about a month now but one thing that I've noticed is it stalls very easily, even if i give it plenty of juice taking off it still seems to stall quite a lot. But just today it stalled at a light coming home from work and I couldn't start it again. turned the key all the way back waited and tried to start then nothing. Then I waited about 10secs (the people behind me weren't too happy :Rolf:) but it started then, and off I went. The engine was turning and all when I tried to start but just wasn't catching.

    Has anyone else encountered this type thing and know what it might be?

    The car is an 06 CDTI Sport Saloon. 100k on the clock new clutch and flywheel @ 85k.

    Thanks!
     
  2. RobB Expert Advisor ★ ★ ★ ★ ★

    Stalling & Hard to start

    Possibly fuel filter needs changing, but would think EML would come on if pressure dropped due to fuel starvation.
     
  3. Doc Expert Advisor ★ ★ ★ ★ ★

    Matt Peterborough
    1,157
    202
    1
    A dirty fuel filter may not report a pressure drop, they have been known to report a whole host of other unrelated problems, even though the filter is the actual fault.

    Check the codes on the EML it should have picked something up when it stalled. That'll take a lot of the guess work out. Keep us updated with any codes you find.
     
    Loading...
  4. trailblazzer Club Member ★ ☆ ☆ ☆ ☆

    Re: Stalling & Hard to start

    That might be it alright, Its due a change now. I just haven't time to do it just yet. Like you said I would imagine that the light would come on if that were a problem. The battery light was on when I was trying to start it but it went out as soon as it did start.

    I'll check if there's any codes stored tomorrow.
     
  5. Doc Expert Advisor ★ ★ ★ ★ ★

    Matt Peterborough
    1,157
    202
    1
    Stalling & Hard to start

    Your battery light will come on when u try 2 restate it, the same as it does before when u first start your car. It's normal, it's because the alternator isn't charging before the engine is running.
     
    Loading...
  6. trailblazzer Club Member ★ ☆ ☆ ☆ ☆

    Just checked the fault codes there with the Obd link and showed there are no codes stored. So seems to be ok. Maybe it was just a once off thing. I'll try change the fuel filter as soon as I can.