Suspension, Steering and Brakes Steering oil leak (behind engine)

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by wahabishtiaq, Sunday 8th May, 2016.

  1. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    Hi Guys,
    Since recent change of clutch i have noticed that my steering oil reservoir level has dropped to low and bubbles when pump is running. Also there is quite a bit oil residue under the steering rod and column. I can see that may be oil is leaking from thick pipe just behind the engine cover....
    Do you guys think that while clutch was done on my accord diesel it could have been that steering column was not put in place correctly? Should i go back to the mechanic who did the clutch on my car?
    Please advise?
    Many thanks
     
    Loading...
  2. Zebster Expert Advisor ★ ★ ★ ★ ★

    United Kingdom .
    2,559
    1,247
    1
    Yes. It looks likely that the steering was not properly reconnected again after it was disconnected to allow the sub-frame to be lowered/removed. Definitely go back and have a chat.
     
    Loading...
  3. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    Thanks Zebster, do you think this may cause a costly repair now or it would be just the case of disconnecting and reconnecting it?. I can see oil dripping from the pipe which is thicker and is just going on the edge and behind the engine cover. Why would this will happen?
     
    Loading...
  4. MickyB Expert Advisor ★ ★ ★ ★ ★

    If it's coming from the union ie the nut part of the pipe there's a possibility that it has not been tightened or that it has been cross threaded when replaced. But most likely the first instance.
     
    Loading...
  5. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    yeah it seems like as the pipe was out of the harness i.e. the socket where it clips just on the edge of engine cover....
     
    Loading...
  6. sc489 Club Member ★ ☆ ☆ ☆ ☆

    My 7th Generation. 2006 Accord has electric steering :Smile:
     
    Loading...
  7. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    Hi,

    Just an update, the PS hose is changed now and leak is stopped. There was a half a inch cut on pipe which was under the bend of pipe away from the obvious. PS hose was £60 from eBay it was aftermarket but good quality. Fitting was easy it was a quick DIY of 30 minutes.

    Now the big job is to clean this all oil residue and give a decent wash, polish and sealant!
     
    Loading...
    Zebster likes this.
  8. Zebster Expert Advisor ★ ★ ★ ★ ★

    United Kingdom .
    2,559
    1,247
    1
    So somehow they cut that pipe while replacing the clutch?
     
    Loading...
  9. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    I don't think so that could have happened, I think it could have been there dormant and while doing the job it got worse. The hose was a genuine factory fitted honda, so did well for 10 yrs.
     
    Loading...
  10. wahabishtiaq Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Wahab Ish hemel hempstead
    99
    22
    Sorry for late update guys, managed to change pipe as a DIY took only 30 mins. Ordered after market new pipe from eBay for £60. Old reside all cleaned and washed.... PSF topped up and reviewed to see if any further leaks. But all looking good.
     
    Loading...
    SpeedyGee and Zebster like this.