Facelift Model Strange Keyless entry problem.

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Alain Camenzuli, Friday 23rd May, 2014.

  1. Alain Camenzuli Junior Member ☆ ☆ ☆ ☆ ☆

    Hi guys,

    I am from malta and recently imported from the UK a 2006 reg ICTDI accord. The car had 99k miles on the clock. I had it serviced and everything. It had 1 problem which bothered me the most and ill try to explain the best way I can.

    The key fobs don't don work with the car it doesnt unlock or lock or even open the booth when i put the key in the driver key barrel and unlock it only the driver door opens the others stay locked. Then i have to put the key in the ignition and turn it to position 2 and unlock it using the driver door lock button.

    The strange part of this is that when i do the programming of the key using the normal method it the buttom on the fob work for 2 seconds and then stop.

    If you didn't understand something feel free to ask thanks.
     
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Sounds like the keyless entry module has failed.
     
    Loading...
  3. Alain Camenzuli Junior Member ☆ ☆ ☆ ☆ ☆

    My guess was there as well but would it explain that the key doesnt open all doors when opened manually and does it explain also that when i do the key programming procedure the fob seems to send commands for 2 seconds and then dies.
     
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,593
    4
    Just get the Keyless entry module replaced and reprogram your keys, that should fix it.

    Search the forum for more info on Keyless entry module, should be fair bit of info.
     
    Loading...
  5. Beefy Expert Advisor ★ ★ ★ ★ ★

    United Kingdom Stoke
    1,115
    685
    1
    it depends if you are carrying out the central locking learn procedure correctly. i could only speculate on how the keys have lost there ''keyless entry'' perhapse they have been replaced after being lost and never coded to the car propperly. ime 99% certain there is a thread on here explaining the procedure, its quite simple but if not done correctly will not code the keys successfully.
     
    Loading...
  6. Alain Camenzuli Junior Member ☆ ☆ ☆ ☆ ☆

    I tried the programming procedure ample times and the lock button when clicked makes the central lock work but after 5 seconds of programming it it stops working completely. Do you still think it the module ? and if so where can i find it to replace it.