Engine & Gearbox Temp loss of power

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Topper Harley, Friday 12th Apr, 2013.

  1. Topper Harley Senior Member ★ ★ ☆ ☆ ☆

    Hey all.

    I've got my 2004 2.2 I-CTDI Tourer for just over a week.
    It's had a couple of problems that i have sorted . One being the exhaust manifold cracked,slight faff but not to bad to do.Drop links and anti roll bar bushes at the rear.

    While driving it yesterday it lost all power for around a mile or so but has driven perfect since :Blink: .
    I checked the ECU for faults and "cam sensor" has shown up.

    Any help or advise would be great.

    Should say its had a service with genuine Honda parts.
  2. Ichiban Founder Staff Team

    England CJ Leeds
    Was the fuel filter changed ? Look for intermittent power loss thread on the forum. It is a tricky one to pin point and fix on diesels.
  3. Topper Harley Senior Member ★ ★ ☆ ☆ ☆

    Yeah it has a new Genuine fuel filter.

    Will have a search for that thread.

  4. Topper Harley Senior Member ★ ★ ☆ ☆ ☆

    Put nearly 400 miles up and no issues at all.

    Maybe just one of those things.
  5. Ichiban Founder Staff Team

    England CJ Leeds
    Good just needed its legs stretching,good old italian tune is does have its advantages.
  6. Roylewaa Club Member ★ ☆ ☆ ☆ ☆

    I love the good old Italian tune up, works wonders

    Reminds me of the Colin Mcrae saying 'If in doubt, flat out'!
  7. Topper Harley Senior Member ★ ★ ☆ ☆ ☆

    It was a great saying too!!!