ICE & HFT Yet another sat-nav problem...

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Galgo, Monday 23rd Feb, 2015.

  1. Galgo Senior Member ★ ★ ☆ ☆ ☆

    I'm under no illusions that the lens on my DVD-ROM drive is dying. Over the weekend I stripped the drive and cleaned the lens with some IPA. The result was its appearance looks shiny rather than cloudy as it did before. I also blasted the dust in the unit away with my trusty "Ultra Jet" air duster. I also did a backup of my scratched sat-nav DVD onto a Verbatim DVD+R disc.

    When I plugged my drive back and used my 'backup' DVD, the system worked and all was well. Except that it only worked for a couple of times and now the TFT screen is blank!

    I'm in contact with Car Hi-Fi Services about replacing the DVD lens on my drive and will send it off to them this week for repair. I was just wondering whether anyone else experienced the same problems and found that the repair cured the DVD read errors and the blank screen?

    The TFT does appear to work as I used it yesterday. When it's blank, you can see the backlight so I reckon the issue is to do with the electronics/controller inside the DVD-ROM drive. I had a quick look for dry joints when the drive was in bits but it was only a brief look; I didn't completely strip it down.

    Thanks guys :Smile:

    Sam
     
    Loading...
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    Are you sure all the connectors were seated back in correctly ?
     
    Loading...
  3. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Yep
     
    Loading...
  4. tonygw Valued Contributor ★ ★ ★ ☆ ☆

    I used car hifi services for my repair, I think if there is a problem they will repair it as apparently they have the complete test set up on their bench, Still waiting for mine to be returned after a bit of a problem. They have been very good.

    Perhaps one of the connectors is loose on the tft screen?

    Just out of interest, how did you back up your dvd disc as I tried all sorts but couldn't get it to back up a working copy. Tried a direct copy and a disc image and both failed to work afterwards but the original (original copy I purchased of the net) works fine. As does the Honda original.

    Cheers
     
    Loading...
  5. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    You need to use dual layer DVDs but copied discs put a greater strain on the laser than original disks. So I'd say they are best avoided.
     
    Loading...
  6. Galgo Senior Member ★ ★ ☆ ☆ ☆

    The screen seems to spring back into life if I disconnect the drive or negative battery lead for a while.

    I follow this guide to backup my Nav disc: How to Backup your Navigation DVD/CD - Steve Jenkins' Blog

    The disc I used was a Verbatim DVD+R DL. The drive never did anything with the original Nav disc, but it works with the copy. Original disc works OK in my PC DVD drive so I guess the laser lens is dying in my car DVD-ROM drive.
     
    Loading...
  7. tonygw Valued Contributor ★ ★ ★ ☆ ☆

    Thats strange, it does sound like there is an issue with the dvd drive affecting the screen. Bit of a long shot but do you have access to a spare drive to try? I am sure CHS will give it a thorough check though.

    Thanks for the back up disc info, very useful I will give it a try as I always wanted to keep a spare copy just in case. I never know with my kids messing about I think one day they will break something like the dvd disc Lol
     
    Loading...
  8. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Nah I've only got the one drive. I thought of getting a used one off eBay but they seem quite expensive, with many costing more than the repair price. It's a shame you can't use an ordinary PC DVD drive. They only cost around £10 brand new!
     
    Loading...
  9. tonygw Valued Contributor ★ ★ ★ ☆ ☆

    Yeah tell me about it. I ummed and errrred about buying second hand but most go for £200 which is rediculous for what is essentially a 10 year old dvd drive.

    Any joy with yours anyway? or have you sent the drive off for repair now?
    Cheers
    Tony
     
    Loading...
  10. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Well that's weird. I haven't driven the car for a few days, went out in it earlier and the screen etc. worked. Sat nav worked too, as it gave me the right directions back to my house. When I got home, I turned the engine off, waited a few seconds and put the ignition on. Blank screen again... :Rant:

    Not sure what to make of that? Thinking about it, the exact same thing happened last time I used it.

    Not sent it off yet. Still thinking about what to do... Part of me wants the OE set up, but part of me wants an upgrade to something newer and better. Don't want to blow £140 + courier costs if I'm just going to remove the head unit and put an aftermarket one in. Been mega busy with work so haven't had time to give the whole saga much thought either.
     
    Loading...
  11. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    14,999
    5,591
    4
    You can't easily replace the Honda Sat Nav with something else due to the way the A/C controls are amalgamated into the Sat Nav.
     
    Loading...
  12. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Yes I know mate :Smile:

    This is one thing I hate about this car. Every other motor I've owned I could fit whatever head unit I wanted without having to modify half the dashboard lol
     
    Loading...