Engine & Gearbox Engine light on 07 Legend

Discussion in '4th Generation (2004-2012) [Acura RL]' started by Philo, Thursday 18th May, 2017.

  1. Philo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Phil St Blazey
    5
    1
    Finally bought myself another Legend, much better than the Merc I had. I've had it now for a couple of weeks with no problems until today when for no reason the engine light on the dash came on. Apparently this is something to do with emissions, can anyone give me any advice please or do I have to take it to a dealer?

    Thanks in advance, Phil
     
    Loading...
  2. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    15,829
    6,680
    4
    You need to get the code read first Phil.

    Get the code read using an OBD reader and post it up here, we can then try and advise you further.
     
    Loading...
    andy83 likes this.
  3. Philo Junior Member ☆ ☆ ☆ ☆ ☆

    United Kingdom Phil St Blazey
    5
    1
    Apologies for the delay getting back to you and thanks for replying. I pulled in a favour from my local Honda dealer and it turns out I confused the system by shifting from forward to reverse to quickly, I did have a gear indicator warning light flash up briefly before the engine light.
    Anyway, they plugged it in and checked everything, then reset the system and all is ok now. Love the car, this is my third Legend, and I still have my old K reg in the garage, might think about moving that one on if anyone is interested.
     
    Loading...
    andy83 likes this.