Epson printer on windows 10

Discussion in 'Lounge & Gossip' started by Harvey, Friday 23rd Sep, 2016.

  1. Harvey Club Veteran ★ ★ ★ ★ ★

    Today there was a major update to windows 10, something like build 1067 or something of that ilk.

    The problem I am now facing is that my printer drivers have fallen off the computer, I downloaded them from the Epson website for my SX215 printer, which now is quite old but still works perfectly (its an all in one printer)

    The problem I now have is that the drivers will not install and it doesn't even seem to recognise the printer as being plugged in to enable installation.

    Here is where it gets fun. I also have an SX235 printer I was given, which the drivers installed no problems, even the scanner part. The problem with that one though is it will not print unless its in yellow, which I think is probably down to the fact it has non genuine cartridges in it. Either way that installed fine, yet the slightly older but better one did not. Any suggestions?
  2. Nels Moderator Staff Team

    Uninstall the 1607 Anniversary update and go back to the 1511 version. MS will send out some fixes/updates to cater for this...eventually.
  3. Harvey Club Veteran ★ ★ ★ ★ ★

    how would I go about that?
  4. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
  5. Nels Moderator Staff Team

    I have not done this, so cannot guarantee that it will not cause other problems.

    You only have 10 days from the upgrade to do this.
    1. Open the Windows 10 settings app
    2. Select 'Updates & Security' and then 'Recovery' from the sub-menu
    3. Click on 'Get Started' underneath the 'Go back to an earlier build' heading
    4. Answer the feedback question with whichever reason is appropriate and click 'Next'
    5. Cycle through the confirmations and alerts until the process begins
    6. Wait for a bit and when finished you will be back to Windows 10 version 1511.
    I'm assuming that you will be able to re-install 1607 later on, but I'm not 100% sure about that. Maybe one of the IT guys can help with that one.

    :Rant: :Rant: :Rant: :Rant: :Rant: @SpeedyGee beat me again! :Sobbing: :Sobbing: :Sobbing: :Sobbing: :Sobbing:
  6. Harvey Club Veteran ★ ★ ★ ★ ★

    Ah, I found what I am looking for, it wasn't the anniversary update, but another one, a different build. it was under the tab for recovery,
    Nels likes this.
  7. FirstHonda Moderator Staff Team

    United Kingdom Ed Wiltshire
  8. Zebster Guest

    I keep having to remove a Win 10 track-pad update from our laptop that results in the track-pad becoming unresponsive when the power lead is unplugged! But it keeps on reapplying that update...
  9. Nels Moderator Staff Team

    Have you tried blocking the update after uninstalling it?
    Zebster likes this.
  10. Zebster Guest

    No. I keep hoping they'll fix the update! But I probably should just block it...
    Nels likes this.
  11. Nels Moderator Staff Team

  12. Harvey Club Veteran ★ ★ ★ ★ ★

    I've given up with that printer, I rolled back the build this morning and even that didn't solve the issue, so I've fixed a newer Epson SX235W that I got given and so far its working fine and all the drivers too.
    Nels and Zebster like this.
  13. Nels Moderator Staff Team

    I've got a multi-boot set-up with XP and W7 so that I can still use my older, and fully functioning, hardware. However, the main printer has some W10 compliant drivers. Not as good as the W7 ones, but enough to cover everyday needs.
    Harvey likes this.
  14. Harvey Club Veteran ★ ★ ★ ★ ★

    Sounds sweet that does @Nels, I got given a Dell Inspiron? desktop pc, 2 monitors the SX235w printer all the bumpf that came with it when new for free. I might wipe the HDD and clean install windows 7 on it at some point. I know the SX215 is a :tut: good printer and ink is still reasonably priced for it. Its too good to throw away
  15. exec Club Veteran ★ ★ ★ ★ ★

    United Kingdom London
    You could if you want try uninstalling and possibly manually removing the epson drives, clean registry and then try installing the drivers, as the updates could have corrupted the old .inf drivers.
    Harvey likes this.
  16. Harvey Club Veteran ★ ★ ★ ★ ★

    I tried to un install, it doesn't do anything, so your right, its probably corrupted the .inf files. also a lot of the time it doesn't recognize that the printer is even plugged in, yet the newer printer, using the same wire has no issues?

    one of the main reasons I liked the old printer as it had a built in SD card reader, which my pc does not have and the usb card reader I have is simply, crap.
    exec likes this.