Service & Maintenance Heater / blower

Discussion in '1st Generation (2004-2011)' started by Ben28, Sunday 2nd Oct, 2016.

  1. Ben28 Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Ben Shetland
    186
    126
    It's seemed a bit weak out of the windscreen vents for a while... Is it just the 2 filters behind the glovebox I need to change?
    I ask because I took these out and it didn't seem to make a difference.

    I had the windscreen replaced while I was... separated... from the car and when we were reunited, it kept fogging up so maybe something got a bit wet that shouldn't have got wet. Just guessing really.

    Anyone more familiar than me with the heater system on this beast? :Smile:

    I've ordered 2 of these to help dry things out

    AirDry Classic Re-Usable Dehumidifier - 1kg (English Version)
     
  2. RobsyUK Valued Contributor ★ ★ ★ ☆ ☆

    United Kingdom Rob Milton Keynes
    472
    172
    It's probably fogging up more because of the rubbish they use when cleaning new screens.
    New screens tend to have a layer of something on them which help them fog - did with me anyways.

    Make sure your fans are on inside (orange light) only when the air con is on.
    Green when you're not using air con.
     
    Loading...
  3. SpeedyGee Administrator Staff Team

    England Speedy Birmingham
    15,887
    6,776
    4
    Loading...
  4. Ben28 Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Ben Shetland
    186
    126
    Removing the filters for a quick test showed no improvement, although I have got a new filter set on order.
    Just wondering if there is anything else I can check down in the gubbins.

    @RobsyUK I think you're right about the coating on the windscreen, it was really bad when it was replaced. I made it a priority to clean it properly.

    Cheers
    B
     
  5. DieselPower Senior Member ★ ★ ☆ ☆ ☆

    If the filters are removed and you have reduced airflow when on max then the transistor on the blower motor could be on its way out or the blower motor is worn. Get this fixed before winter!! I posted my issues with my blower motor a few months ago I'll see if I can dig it out.
     
    Loading...
  6. Ben28 Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Ben Shetland
    186
    126
    thing is though it's very strong out of the face vents when on max it takes your head off, it's just the windscreen vents that feel almost like they're not on at all
     
  7. DieselPower Senior Member ★ ★ ☆ ☆ ☆

    OK, sounds like the air flow control flaps for the windshield are not responding to the heater control or they are stuck or the motor that controls them has an issue. You can buy a £15 USB endoscopic type camera with a light and feed it in the vent to look for blockages but it might be better to get a Honda HDS scan I think they have specific checks that they can do on the heater control modules.
     
    Loading...
  8. Ben28 Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Ben Shetland
    186
    126
  9. DieselPower Senior Member ★ ★ ☆ ☆ ☆

    Ahh didn't realise you don't have easy access to a dealer. I've heard ppl mention Chinese HDS clones, dunno if they are any good. Hopefully someone more knowledgeable on the HDS can chime in about these clones and their diagnostic ability with regard to the heater controls. I just remember reading about HDS heater module diagnostics when looking into my heater issue.
    Can't see the HDS actually fixing anything so you may well end up having to go to mainland anyway.
     
    Loading...
    Ben28 likes this.
  10. Ben28 Senior Member ★ ★ ☆ ☆ ☆

    United Kingdom Ben Shetland
    186
    126
  11. danfrv New Member Getting Started

    United Kingdom dan st neots
    2
    My blower has stopped working and tried changing the resistor but it still didn't work. May be the motor? I tried to unscrew it but one of the screws is a pain to get to. There is a box under it and don't know how to get past it. Any advice?
     
  12. DieselPower Senior Member ★ ★ ☆ ☆ ☆

    https://hondakarma.com/threads/dead-heater-blower-motor.23221/live
    Look at this link. I had issues with my motor which I documented
    Unfortunately the images are gone. In fact images on the site haven't been right for a while now?
     
    Loading...
  13. danfrv New Member Getting Started

    United Kingdom dan st neots
    2
    Thanks mate. It is the blower and I've taken it to a local garage to put in a recon one. £150 all in. I missed your post by a few days otherwise I would of got one off eBay for about £60