ICE & HFT Xcarlink bluetooth- no audio out?

Discussion in '7th Generation (2003-2008) [Acura TSX]' started by Badger, Wednesday 3rd Jun, 2015.

  1. Badger Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Derby
    Calling all Xcarlink users/ installers pretty please...

    Got bored with radio and my Val Doonican CD so recently purchased the Xcarlink SKU 703 Bluetooth interface for my 7th Generation with Nav (thanks to recommendations on here)... Prior to arrival I searched and found the super handy Accord install... well chuffed as I fear removing interiors... :Niceone:

    Needless to say the install was a doddle, powered up the car and paired the Xcarlink to my iPhone. The system auto detected the "aux" input and displayed the CDC on the secondary display as per the Chinglish instluctions. All good so far. Selected music, hit play, and... nothing?? Volume controls on the steering wheels work as advertised and also track select. Even tried the 3.5mm cable input but with similar results.

    Managed last night to convince my mate with a non nav Accord to let me try it in his car. Easier install - same results!!

    I could see prior to dismantle of the dash that there was previously a hands free kit installed. I worked out that the remaining loom was just plugged in-line between the car loom and what I believe to be an amp below the nav drive. Having removed the loom the car is now "pre hands free".

    I have been in touch with Xcarlink who have asked me to ensure that the unit is plugged in to the CD changer input, which I don't believe my unit has as it's a combined unit and the aux in is the spare white connector?

    I suspect the Xcarlink is faulty, having tried it on two cars, however just wanted to ask those with experience, have I missed something obvious?

    Thanks all.

  2. Galgo Senior Member ★ ★ ☆ ☆ ☆

    I have Xcarlink and mine works OK. My car has nav too and it's got the CD changer port. I think all 7th Generation head units do.

    Follow the Xcarlink installation guide here if you're not sure: "xcarlink" MP3 Unit Install

    That's what I did as I bought mine secondhand and it didn't come with any instructions.
  3. Badger Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Derby
    Hi Galgo,

    Thanks for the prompt reply. That install is identical to the one I followed, can't see how you could get it wrong.

    I'll try for a replacement unit...

  4. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Two more things to check:

    1. The volume on your device and on the head unit is turned up

    2. The iPod cable hasn't got any bent or missing pins at the Xcarlink end, and that the cable is fully pushed into the unit

    Also, is there any sound if you play your music over Bluetooth?
  5. Badger Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Derby
    Checked both the phone volume and head unit, had them both at max in fact. Nothing.

    There is no cable attachment as it's Bluetooth, even the USB is only for charging, not audio. There is a 3.5 mm input but that has the same results.

    Not really many more troubleshooting steps sadly...

    I've been in touch with Xcarlink to see what they think. I regret not buying the version with SD and USB input so hope I can swap it out for one of those...
  6. Galgo Senior Member ★ ★ ☆ ☆ ☆

    Oh I think your one is different to mine then. Mine is the standard Xcarlink one like in that tutorial I linked to, but with an additional BT cable.

    Hopefully they'll sort you out a replacement soon, it sounds like you've just had bad luck and got sent a faulty unit.
  7. Badger Club Member ★ ☆ ☆ ☆ ☆

    United Kingdom Derby
    Galgo likes this.